#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(,)(?=(?:[^"]|"[^"]*")*$)"
Local $sString = "2020-12-01,Donderdag,https://open.spotify.com/track/3uT4d8m0FfQRouoav48ra6,67,"Kris Kross Amsterdam,Bilal Wahib,Emma Heesters","https://open.spotify.com/artist/4LcUpNlXFEleaLlelmkv2R,https://open.spotify.com/artist/5wV3FoaNbDB6X9INuQvs1K,https://open.spotify.com/artist/3898xesz6JuQkpz7Kiu4uM",33,67,41,47498,2020-10-21,2020-10-22,81,"Kris Kross Amsterdam,Yuyu van Scheppingen,Joren van der Voort,Bas van Daalen,Joey Ferre","Paul Sinha,B9NNY,Bas van Daalen,Bilal Wahib,Emma Heesters,Joey Ferre,Joost Theo Sylvio Yussef Abdelgalil Dowib,Jordy Huisman,Joren van der Voort,Sander Huisman,Yuki Kempees",Top Notch Music BV"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")