import Foundation
let pattern = #"(,)(?=(?:[^"]|"[^"]*")*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"2020-12-01,Donderdag,https://open.spotify.com/track/3uT4d8m0FfQRouoav48ra6,67,"Kris Kross Amsterdam,Bilal Wahib,Emma Heesters","https://open.spotify.com/artist/4LcUpNlXFEleaLlelmkv2R,https://open.spotify.com/artist/5wV3FoaNbDB6X9INuQvs1K,https://open.spotify.com/artist/3898xesz6JuQkpz7Kiu4uM",33,67,41,47498,2020-10-21,2020-10-22,81,"Kris Kross Amsterdam,Yuyu van Scheppingen,Joren van der Voort,Bas van Daalen,Joey Ferre","Paul Sinha,B9NNY,Bas van Daalen,Bilal Wahib,Emma Heesters,Joey Ferre,Joost Theo Sylvio Yussef Abdelgalil Dowib,Jordy Huisman,Joren van der Voort,Sander Huisman,Yuki Kempees",Top Notch Music BV"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)