re = /(,)(?=(?:[^"]|"[^"]*")*$)/m
str = '2020-12-01,Donderdag,https://open.spotify.com/track/3uT4d8m0FfQRouoav48ra6,67,"Kris Kross Amsterdam,Bilal Wahib,Emma Heesters","https://open.spotify.com/artist/4LcUpNlXFEleaLlelmkv2R,https://open.spotify.com/artist/5wV3FoaNbDB6X9INuQvs1K,https://open.spotify.com/artist/3898xesz6JuQkpz7Kiu4uM",33,67,41,47498,2020-10-21,2020-10-22,81,"Kris Kross Amsterdam,Yuyu van Scheppingen,Joren van der Voort,Bas van Daalen,Joey Ferre","Paul Sinha,B9NNY,Bas van Daalen,Bilal Wahib,Emma Heesters,Joey Ferre,Joost Theo Sylvio Yussef Abdelgalil Dowib,Jordy Huisman,Joren van der Voort,Sander Huisman,Yuki Kempees",Top Notch Music BV'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end