import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]+([,.]?[0-9]+)?[ ]?[A-Za-z]+";
final String string = "This is the recipe to do a cake:\n"
+ "1 cup of oil (120ml).\n"
+ "3 cups of flour (350g).\n"
+ "2 un of eggs.\n"
+ "1,5 cup of milk (180ml).\n"
+ "2 spoons of sugar (50g)\n"
+ "1 teaspoon of Salt.\n"
+ "Mix for 7 minutes in the mixer or 10 minutes by hand. Preheat the oven at 180 C for 5 min. Cook for between 35 and 50 min.\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}