re = /[0-9]+([,.]?[0-9]+)?[ ]?[A-Za-z]+/m
str = 'This is the recipe to do a cake:
1 cup of oil (120ml).
3 cups of flour (350g).
2 un of eggs.
1,5 cup of milk (180ml).
2 spoons of sugar (50g)
1 teaspoon of Salt.
Mix for 7 minutes in the mixer or 10 minutes by hand. Preheat the oven at 180 C for 5 min. Cook for between 35 and 50 min.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end