import re
regex = re.compile(r"[0-9]+([,.]?[0-9]+)?[ ]?[A-Za-z]+", flags=re.MULTILINE)
test_str = ("This is the recipe to do a cake:\n"
"1 cup of oil (120ml).\n"
"3 cups of flour (350g).\n"
"2 un of eggs.\n"
"1,5 cup of milk (180ml).\n"
"2 spoons of sugar (50g)\n"
"1 teaspoon of Salt.\n"
"Mix for 7 minutes in the mixer or 10 minutes by hand. Preheat the oven at 180 C for 5 min. Cook for between 35 and 50 min.\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")