package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z][\w\d_]+@[a-zA-Z]{3,20}\.[a-z]{3}$`)
var str = `mostafamahmoud@gmail.com
mostafamahmoud@gmailcom`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}