re = /^[a-zA-Z][\w\d_]+@[a-zA-Z]{3,20}\.[a-z]{3}$/m
str = 'mostafamahmoud@gmail.com
mostafamahmoud@gmailcom'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end