$re = '/^[a-zA-Z][\w\d_]+@[a-zA-Z]{3,20}\.[a-z]{3}$/m';
$str = 'mostafamahmoud@gmail.com
mostafamahmoud@gmailcom';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);