import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![^-\\n]*(?:-(?!\\.)[^-\\n]*)*-\\.)(?:(?!-)[A-Za-z0-9-]{1,63}\\.)+[A-Za-z]{2,63}$";
final String string = "Abc12.com\n"
+ "A-bc-12.com\n"
+ "Ab---c12.com\n"
+ "A.bc.123.2567.com\n"
+ "A.bc.12-3.2-56-7.com\n\n"
+ "-Abc12.com\n"
+ "Abc12.c\n"
+ "Abc12-.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}