const regex = /^(?![^-\n]*(?:-(?!\.)[^-\n]*)*-\.)(?:(?!-)[A-Za-z0-9-]{1,63}\.)+[A-Za-z]{2,63}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![^-\\n]*(?:-(?!\\.)[^-\\n]*)*-\\.)(?:(?!-)[A-Za-z0-9-]{1,63}\\.)+[A-Za-z]{2,63}$', 'gm')
const str = `Abc12.com
A-bc-12.com
Ab---c12.com
A.bc.123.2567.com
A.bc.12-3.2-56-7.com
-Abc12.com
Abc12.c
Abc12-.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}