$re = '/^(?![^-\n]*(?:-(?!\.)[^-\n]*)*-\.)(?:(?!-)[A-Za-z0-9-]{1,63}\.)+[A-Za-z]{2,63}$/m';
$str = 'Abc12.com
A-bc-12.com
Ab---c12.com
A.bc.123.2567.com
A.bc.12-3.2-56-7.com
-Abc12.com
Abc12.c
Abc12-.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);