using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#[^#\s]*";
string input = @"put retur#ERns between #errf #fgrf#re paragraphs #fg^%tg2#785Ty*";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}