re = /#[^#\s]*/
str = 'put retur#ERns between #errf #fgrf#re paragraphs #fg^%tg2#785Ty*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end