$re = '/#[^#\s]*/';
$str = 'put retur#ERns between #errf #fgrf#re paragraphs #fg^%tg2#785Ty*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);