using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:GB\d{2}[A-Z]{4}\d{14}|DE\d{20})$";
string input = @"works as expected
DE12312341212312312312
GB12AFDF12312312312311
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}