// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:GB\d{2}[A-Z]{4}\d{14}|DE\d{20})$").unwrap();
let string = "works as expected
DE12312341212312312312
GB12AFDF12312312312311
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}