$re = '/^(?:GB\d{2}[A-Z]{4}\d{14}|DE\d{20})$/m';
$str = 'works as expected
DE12312341212312312312
GB12AFDF12312312312311
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);