#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?miu)([^,\s][^,]*)\s*:\s*(.*?)(?=[^,\n]*:|$)"
Local $sString = "Gérant : Jean-Pierre LEVENDEAIN, Associé : Toumiat, Farid" & @CRLF & _
"Gérant : Jean-Pierre, LEVENDEAIN, Associé : Toumiat, Farid" & @CRLF & _
"" & @CRLF & _
"Président : Chateau, Nathalie, nom d'usage : Rudzinski, Directeur général : Montmirel, Joëlle, nom d'usage : Ciocco, Directeur général délégué : Rudzinski, Stéphane."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")