use strict;
my $str = 'Gérant : Jean-Pierre LEVENDEAIN, Associé : Toumiat, Farid
Gérant : Jean-Pierre, LEVENDEAIN, Associé : Toumiat, Farid
Président : Chateau, Nathalie, nom d\'usage : Rudzinski, Directeur général : Montmirel, Joëlle, nom d\'usage : Ciocco, Directeur général délégué : Rudzinski, Stéphane.';
my $regex = qr/([^,\s][^,]*)\s*:\s*(.*?)(?=[^,\n]*:|$)/miup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}