$re = '/([^,\s][^,]*)\s*:\s*(.*?)(?=[^,\n]*:|$)/miu';
$str = 'Gérant : Jean-Pierre LEVENDEAIN, Associé : Toumiat, Farid
Gérant : Jean-Pierre, LEVENDEAIN, Associé : Toumiat, Farid
Président : Chateau, Nathalie, nom d\'usage : Rudzinski, Directeur général : Montmirel, Joëlle, nom d\'usage : Ciocco, Directeur général délégué : Rudzinski, Stéphane.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);