import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^\\s*(?:[\\w<>]+\\s+){2}(?!\\w+\\s\\{get;set;\\}.*$)|\\G)\\K(\\w+)(\\h*)(?=.*\\s\\{get;set;\\}.*$)";
final String string = " public BusinessProcessTaskStatus Status {get;set;} \n\n"
+ " public HcmEmploymentType WorkerType {get;set;} \n\n"
+ " public string OnboardedEmployeeEmail {get;set;} \n\n"
+ " public BusinessProcessGenericSubtype GenericSubtype {get;set;} \n\n"
+ " public BaseWorker Assigned worker {get;set;} \n\n"
+ " public ProcessTask Process task {get;set;} \n\n"
+ " public BaseWorker Resolved by {get;set;} \n"
+ " public string dataAreaId {get;set;} //PrimaryKey not null\n\n"
+ " public List<ProcessTemplateTask> Assigned template tasks {get;set;} \n\n"
+ " public List<ProcessTask> Assigned tasks {get;set;} ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}