import Foundation
let pattern = #"(?:^\s*(?:[\w<>]+\s+){2}(?!\w+\s\{get;set;}.*$)|\G)\K(\w+)(\h*)(?=.*\s\{get;set;}.*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
public BusinessProcessTaskStatus Status {get;set;}
public HcmEmploymentType WorkerType {get;set;}
public string OnboardedEmployeeEmail {get;set;}
public BusinessProcessGenericSubtype GenericSubtype {get;set;}
public BaseWorker Assigned worker {get;set;}
public ProcessTask Process task {get;set;}
public BaseWorker Resolved by {get;set;}
public string dataAreaId {get;set;} //PrimaryKey not null
public List<ProcessTemplateTask> Assigned template tasks {get;set;}
public List<ProcessTask> Assigned tasks {get;set;}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)