use strict;
my $str = ' public BusinessProcessTaskStatus Status {get;set;}
public HcmEmploymentType WorkerType {get;set;}
public string OnboardedEmployeeEmail {get;set;}
public BusinessProcessGenericSubtype GenericSubtype {get;set;}
public BaseWorker Assigned worker {get;set;}
public ProcessTask Process task {get;set;}
public BaseWorker Resolved by {get;set;}
public string dataAreaId {get;set;} //PrimaryKey not null
public List<ProcessTemplateTask> Assigned template tasks {get;set;}
public List<ProcessTask> Assigned tasks {get;set;} ';
my $regex = qr/(?:^\s*(?:[\w<>]+\s+){2}(?!\w+\s\{get;set;}.*$)|\G)\K(\w+)(\h*)(?=.*\s\{get;set;}.*$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}