#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?A)^(?:((бл\.\s?)?\p{N}{1,4}[\s-]?\p{Cyrillic}?)|((\p{N}{1,4}-){0,2}\p{N}{1,4}))$"
Local $sString = "2-4-6-8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")