package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:((бл\.\s?)?\p{N}{1,4}[\s-]?\p{Cyrillic}?)|((\p{N}{1,4}-){0,2}\p{N}{1,4}))$`)
var str = `2-4-6-8`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}