$re = '/^(?:((бл\.\s?)?\p{N}{1,4}[\s-]?\p{Cyrillic}?)|((\p{N}{1,4}-){0,2}\p{N}{1,4}))$/A';
$str = '2-4-6-8';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);