package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\.(ico|css|js|gif|jpe?g|png)(\?[0-9]+)?$`)
var str = `/img/signup/be0e1d34fabf2514d49db9baec09f858.png?w=198&h=198&s=9a7d22504c5ae176a936a0f18cccacba`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}