re = /\.(ico|css|js|gif|jpe?g|png)(\?[0-9]+)?$/
str = '/img/signup/be0e1d34fabf2514d49db9baec09f858.png?w=198&h=198&s=9a7d22504c5ae176a936a0f18cccacba'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end