const regex = /\.(ico|css|js|gif|jpe?g|png)(\?[0-9]+)?$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(ico|css|js|gif|jpe?g|png)(\\?[0-9]+)?$', 'g')
const str = `/img/signup/be0e1d34fabf2514d49db9baec09f858.png?w=198&h=198&s=9a7d22504c5ae176a936a0f18cccacba`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}