import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?=.*%)(?![A-Z]{1,5}[0-9])(?:%?[A-Z]){0,6}(?:(?:%?[A-Z0-9]){1,2})?(?:(?:%?[A-Z]){1,3})?%?)$|^(?:[A-Z]{6}(?:[A-Z0-9]{2})(?:[A-Z]{3})?)$|^$";
final String string = "\n"
+ "-> correct: Empty string\n"
+ "AaBB%\n"
+ "ABCDE%\n"
+ "AAAAAA33\n"
+ "AABBCCXX\n"
+ "AABBCC44XXX\n"
+ " -> correct\n"
+ "AA%33\n"
+ " -> correct ( % avoid the max number)\n"
+ "%AAB%BCC4%4X%XX%\n"
+ " -> correct (because % should be ignored in length, length of alpha and alphanumeric is respected here)\n"
+ "A%3\n"
+ "AA%33%\n"
+ "%AA33%\n"
+ "%AA3%\n"
+ "%3\n"
+ " -> correct according comments\n"
+ " ----------------------------------------------\n"
+ "AABBCCXXX\n"
+ "AABBCC44XX\n"
+ " -> wrong\n"
+ "AABb\n"
+ "AAbbCC\n"
+ "ABCDEF\n"
+ " -> wrong (need exactly 6 alpha + 2 alphanumeric when there is no %)\n"
+ "AAABB3%\n"
+ " -> wrong (need exactly 6 alpha before numeric)\n"
+ "AABBCC44XXXE\n"
+ " -> wrong (length of alpha not respected)\n"
+ "%AABBCC44XXXE\n"
+ " -> wrong (length of alpha not respected)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}