use strict;
my $str = '
-> correct: Empty string
AaBB%
ABCDE%
AAAAAA33
AABBCCXX
AABBCC44XXX
-> correct
AA%33
-> correct ( % avoid the max number)
%AAB%BCC4%4X%XX%
-> correct (because % should be ignored in length, length of alpha and alphanumeric is respected here)
A%3
AA%33%
%AA33%
%AA3%
%3
-> correct according comments
----------------------------------------------
AABBCCXXX
AABBCC44XX
-> wrong
AABb
AAbbCC
ABCDEF
-> wrong (need exactly 6 alpha + 2 alphanumeric when there is no %)
AAABB3%
-> wrong (need exactly 6 alpha before numeric)
AABBCC44XXXE
-> wrong (length of alpha not respected)
%AABBCC44XXXE
-> wrong (length of alpha not respected)';
my $regex = qr/^(?:(?=.*%)(?![A-Z]{1,5}[0-9])(?:%?[A-Z]){0,6}(?:(?:%?[A-Z0-9]){1,2})?(?:(?:%?[A-Z]){1,3})?%?)$|^(?:[A-Z]{6}(?:[A-Z0-9]{2})(?:[A-Z]{3})?)$|^$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}