const regex = /^(?:(?=.*%)(?![A-Z]{1,5}[0-9])(?:%?[A-Z]){0,6}(?:(?:%?[A-Z0-9]){1,2})?(?:(?:%?[A-Z]){1,3})?%?)$|^(?:[A-Z]{6}(?:[A-Z0-9]{2})(?:[A-Z]{3})?)$|^$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?=.*%)(?![A-Z]{1,5}[0-9])(?:%?[A-Z]){0,6}(?:(?:%?[A-Z0-9]){1,2})?(?:(?:%?[A-Z]){1,3})?%?)$|^(?:[A-Z]{6}(?:[A-Z0-9]{2})(?:[A-Z]{3})?)$|^$', 'gmi')
const str = `
-> correct: Empty string
AaBB%
ABCDE%
AAAAAA33
AABBCCXX
AABBCC44XXX
-> correct
AA%33
-> correct ( % avoid the max number)
%AAB%BCC4%4X%XX%
-> correct (because % should be ignored in length, length of alpha and alphanumeric is respected here)
A%3
AA%33%
%AA33%
%AA3%
%3
-> correct according comments
----------------------------------------------
AABBCCXXX
AABBCC44XX
-> wrong
AABb
AAbbCC
ABCDEF
-> wrong (need exactly 6 alpha + 2 alphanumeric when there is no %)
AAABB3%
-> wrong (need exactly 6 alpha before numeric)
AABBCC44XXXE
-> wrong (length of alpha not respected)
%AABBCC44XXXE
-> wrong (length of alpha not respected)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}