use strict;
my $str = '1 testbtblal balbl al2845 tetete gsgsgs tetet
2 testblablablablal gsgsg gsgs gsgsg gsg
3 blabltetst alets jff <-----
4 125testblabal14test ablets blbla
5 test2584blaalj
contains "bla" text
7 4rblatesbaltest845 testblabla test
8 blabalbal878testbaltesbla blabla test
9 2584blaal jstba lest <------
10 blablatest5 45blabla ffftest
';
my $regex = qr/^.{21,}$(*SKIP)(*FAIL)|bla/mp;
my $subst = 'SOME_NEW_STRING';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";