re = /^.{21,}$(*SKIP)(*FAIL)|bla/m
str = '1 testbtblal balbl al2845 tetete gsgsgs tetet
2 testblablablablal gsgsg gsgs gsgsg gsg
3 blabltetst alets jff <-----
4 125testblabal14test ablets blbla
5 test2584blaalj
contains "bla" text
7 4rblatesbaltest845 testblabla test
8 blabalbal878testbaltesbla blabla test
9 2584blaal jstba lest <------
10 blablatest5 45blabla ffftest
'
subst = 'SOME_NEW_STRING'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result