#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?=\()(?:(?=.*?\((?!.*?\1)(.*\)(?!.*\2).*))(?=.*?\)(?!.*?\2)(.*)).)+?.*?(?=\1)[^(]*(?=\2$)"
Local $sString = "Answer ((((((((((misery)))))))))) adieus add wooded how nay men before though. Pretended belonging contented (mrs suffering favourite you the continual). Mrs civil nay least means tried drift. (Natural) (end) (law) whether but and towards certain. (Furnished (unfeeling his sometimes (see day promotion. Quitting) informed concerns) can men now). Projection to or up conviction uncommonly delightful continuing. In appetite ecstatic opinions hastened by handsome admitted." & @CRLF & _
"" & @CRLF & _
"Answer misery adieus add wooded how nay men before though. Pretended belonging contented (mrs suffering favourite you the continual). Mrs civil nay least means tried drift. (Natural) (end) (law) whether but and towards certain. (Furnished (unfeeling his sometimes (see) day promotion. Quitting) informed concerns) can men now. Projection to or up conviction uncommonly delightful continuing. In appetite ecstatic opinions hastened by handsome (((admitted. " & @CRLF & _
"" & @CRLF & _
"Answer misery))) adieus add wooded how nay men before though. Pretended belonging contented mrs suffering favourite you the continual. Mrs civil nay least means tried drift. (Natural) (end) (law) whether but and towards certain. (Furnished (unfeeling his sometimes (see day promotion. Quitting) informed concerns) can men now). Projection to or up conviction uncommonly delightful continuing. In appetite ecstatic opinions hastened by handsome admitted."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")