re = /(?=\()(?:(?=.*?\((?!.*?\1)(.*\)(?!.*\2).*))(?=.*?\)(?!.*?\2)(.*)).)+?.*?(?=\1)[^(]*(?=\2$)/
str = 'Answer ((((((((((misery)))))))))) adieus add wooded how nay men before though. Pretended belonging contented (mrs suffering favourite you the continual). Mrs civil nay least means tried drift. (Natural) (end) (law) whether but and towards certain. (Furnished (unfeeling his sometimes (see day promotion. Quitting) informed concerns) can men now). Projection to or up conviction uncommonly delightful continuing. In appetite ecstatic opinions hastened by handsome admitted.
Answer misery adieus add wooded how nay men before though. Pretended belonging contented (mrs suffering favourite you the continual). Mrs civil nay least means tried drift. (Natural) (end) (law) whether but and towards certain. (Furnished (unfeeling his sometimes (see) day promotion. Quitting) informed concerns) can men now. Projection to or up conviction uncommonly delightful continuing. In appetite ecstatic opinions hastened by handsome (((admitted.
Answer misery))) adieus add wooded how nay men before though. Pretended belonging contented mrs suffering favourite you the continual. Mrs civil nay least means tried drift. (Natural) (end) (law) whether but and towards certain. (Furnished (unfeeling his sometimes (see day promotion. Quitting) informed concerns) can men now). Projection to or up conviction uncommonly delightful continuing. In appetite ecstatic opinions hastened by handsome admitted.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end