const regex = /^(\/\w+){6}\/(?<djs>\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\\/\\w+){6}\\\/(?<djs>\\d+)', 'gm')
const str = `/api/sns/exts/djs/310200019110274535/ds/310200019110274536/.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}