re = /^(\/\w+){6}\/(?<djs>\d+)/m
str = '/api/sns/exts/djs/310200019110274535/ds/310200019110274536/.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end