$re = '/^(\/\w+){6}\/(?<djs>\d+)/m';
$str = '/api/sns/exts/djs/310200019110274535/ds/310200019110274536/.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);