using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<train>((<\[[^a-zA-Z0-9]*\]\.){1})((\.\[[a-zA-Z0-9]*\]\.))*)$";
string input = @"<[{]..[7]..[]..[]..[C2I43].
<[(_#/}$)$]..[GO5A]..[G5]..[3W4].
<[^]..[54]..[S].
<[@].
<[)$-{,]..[PB1N]..[R757G].
<[]..[]..[10]..[223F]..[GBM4].
<[!]..[]
<[)_]..[3N]..[TS]..[0NS58].
Traincode!";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}