package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<train>((<\[[^a-zA-Z0-9]*\]\.){1})((\.\[[a-zA-Z0-9]*\]\.))*)$`)
var str = `<[{]..[7]..[]..[]..[C2I43].
<[(_#/}$)$]..[GO5A]..[G5]..[3W4].
<[^]..[54]..[S].
<[@].
<[)$-{,]..[PB1N]..[R757G].
<[]..[]..[10]..[223F]..[GBM4].
<[!]..[]
<[)_]..[3N]..[TS]..[0NS58].
Traincode!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}