#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mui)^(?:[а-яё]()|\d())++\1\2$"
Local $sString = "111" & @CRLF & _
"АД111" & @CRLF & _
"125АВАВАВ" & @CRLF & _
"ыва234цуёк" & @CRLF & _
"ГКМ" & @CRLF & _
"123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")