re = /^(?:[а-яё]()|\d())++\1\2$/mi
str = '111
АД111
125АВАВАВ
ыва234цуёк
ГКМ
123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end