import re
regex = re.compile(r"^(?:[а-яё]()|\d())++\1\2$", flags=re.MULTILINE | re.UNICODE | re.IGNORECASE)
test_str = ("111\n"
"АД111\n"
"125АВАВАВ\n"
"ыва234цуёк\n"
"ГКМ\n"
"123")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")