import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^B2B_[^_.]*(_([0-9]+))?(_([A-Za-z]+))?";
final String string = "B2B_1111108A20.jpg\n"
+ "B2B_1111108A20_1.jpg\n"
+ "B2B_1111108A20_2_S.jpg\n"
+ "B2B_1111108A20_3_ST.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}