$re = '/^B2B_[^_.]*(_([0-9]+))?(_([A-Za-z]+))?/m';
$str = 'B2B_1111108A20.jpg
B2B_1111108A20_1.jpg
B2B_1111108A20_2_S.jpg
B2B_1111108A20_3_ST.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);