use strict;
my $str = 'B2B_1111108A20.jpg
B2B_1111108A20_1.jpg
B2B_1111108A20_2_S.jpg
B2B_1111108A20_3_ST.jpg';
my $regex = qr/^B2B_[^_.]*(_([0-9]+))?(_([A-Za-z]+))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}