# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(wsrep_provider_options(?!.*\bgcache.size\b).*)('$)/\1; gcache.size=4G\2/gm;t' <<< "wsrep_provider_options='gmcast.segment=0; ist.recv_addr=tcp://db7; ist.recv_bind=tcp://0.0.0.0; socket.ssl_cert=/etc/mysql/wsrep/ssl/gmnode.pem; socket.ssl_key=/etc/mysql/wsrep/ssl/gmnode.key; socket.ssl_ca=/etc/mysql/wsrep/ssl/gmca.pem'
wsrep_provider_options='gmcast.segment=0; ist.recv_addr=tcp://db7; ist.recv_bind=tcp://0.0.0.0; socket.ssl_cert=/etc/mysql/wsrep/ssl/gmnode.pem; socket.ssl_key=/etc/mysql/wsrep/ssl/gmnode.key; socket.ssl_ca=/etc/mysql/wsrep/ssl/gmca.pem; gcache.size=4G'
wsrep_provider_options='gcache.size=4G; gmcast.segment=0; ist.recv_addr=tcp://db7; ist.recv_bind=tcp://0.0.0.0; socket.ssl_cert=/etc/mysql/wsrep/ssl/gmnode.pem; socket.ssl_key=/etc/mysql/wsrep/ssl/gmnode.key; socket.ssl_ca=/etc/mysql/wsrep/ssl/gmca.pem'"