import re
regex = re.compile(r"^(wsrep_provider_options(?!.*\bgcache.size\b).*)('$)", flags=re.MULTILINE)
test_str = ("wsrep_provider_options='gmcast.segment=0; ist.recv_addr=tcp://db7; ist.recv_bind=tcp://0.0.0.0; socket.ssl_cert=/etc/mysql/wsrep/ssl/gmnode.pem; socket.ssl_key=/etc/mysql/wsrep/ssl/gmnode.key; socket.ssl_ca=/etc/mysql/wsrep/ssl/gmca.pem'\n\n"
"wsrep_provider_options='gmcast.segment=0; ist.recv_addr=tcp://db7; ist.recv_bind=tcp://0.0.0.0; socket.ssl_cert=/etc/mysql/wsrep/ssl/gmnode.pem; socket.ssl_key=/etc/mysql/wsrep/ssl/gmnode.key; socket.ssl_ca=/etc/mysql/wsrep/ssl/gmca.pem; gcache.size=4G'\n\n"
"wsrep_provider_options='gcache.size=4G; gmcast.segment=0; ist.recv_addr=tcp://db7; ist.recv_bind=tcp://0.0.0.0; socket.ssl_cert=/etc/mysql/wsrep/ssl/gmnode.pem; socket.ssl_key=/etc/mysql/wsrep/ssl/gmnode.key; socket.ssl_ca=/etc/mysql/wsrep/ssl/gmca.pem'")
subst = "\\1; gcache.size=4G\\2"
result = regex.sub(subst, test_str)
if result:
print(result)